How to downgrade Kotlin version

Issue

I’ve build a complete empty Project and I got this error:

e: This version (1.0.0-alpha13) of the Compose Compiler requires Kotlin version 1.4.30 but you appear to be using Kotlin version 1.4.32 which is not known to be compatible. Please fix your configuration (or suppressKotlinVersionCompatibilityCheck but don’t say I didn’t warn you!).

What can I do? (Sorry for this dumb question, but I’m complete new to Kotlin)

Thanks, Boothosh

Solution

You can go to Plugins in the IDE settings and uninstall the Kotlin one there, and do Install From Disk (under the gear icon) and use one of these: https://plugins.jetbrains.com/plugin/6954-kotlin/versions – you’d probably need to update your gradle files too (I haven’t done any of this before so I can’t tell you if it works or if you’ll run into problems)

Why not just use a newer version of Compose though? They’re up to beta 6 now – I can’t even see an alpha 13 listed! Seems like a better idea all round, unless there’s a really specific reason you need that version you’re using?

Answered By – cactustictacs

Leave a Comment