The ‘kotlin-android-extensions’ Gradle plugin is deprecated

Issue

with the Gradle version 6.2 and Android studio version 4.0.1, I have the deprecation message for the Kotlin-android-extention. any body has any idea how to fix it.

Solution

It’s deprecated Base on the google document

Kotlin Android Extensions is deprecated, which means that using Kotlin synthetics for view binding is no longer supported.

for those who’s wonder what the synthetic is. I should say a simple way to access to UI view id with kotlin which was possible by adding 'kotlin-android-extensions' in Gradle.

  • If your app uses Parcelable you can use 'kotlin-parcelize' instead of 'kotlin-android-extensions'.
  • If your app uses Kotlin synthetics for view binding, use this guide to migrate to Jetpack ViewBinding or Data Binding.

Answered By – Ali shatergholi

Leave a Comment